Investigating MyVistage site connection error messages (unable to connect or unsupported protocol)

Incident Report for Vistage

Resolved

An issue with our hosting provider was identified and resolved, again our apologies for the disruption.

Need assistance with a Vistage-related technical issue? Reach out to our IT Support team! 888.261.3911 | support@vistage.com | chat.vistage.com Vistage IT Support is staffed M - F, 6 a.m. - 6 p.m. PT
Posted Jun 01, 2026 - 17:07 PDT

Investigating

We are currently investigating connection errors when visiting MyVistage - our apologies for the disruption, an update will be posted asap.
Posted Jun 01, 2026 - 16:53 PDT
This incident affected: MyVistage Member and Chair portals (MyVistage Portal, Calendar, ChairNet, Matrix speaker scheduling system, Online Membership Application, Speaker Directory, Meeting Notices).