Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 16, 2024 - 18:00 PST
Scheduled
IT SERVICE ADVISORY: Chairmail & Staff Email Maintenance - Fri., Feb. 16, 6 - 8 p.m. PST
Tonight - Friday, February 16, beginning at 6 p.m. PST, we will be performing scheduled maintenance on our Chairmail & Staff email platforms. Messages received during the maintenance period will be queued and released upon completion. Maintenance duration is expected to be two hours with full restoration of services by 8 p.m.
Please close your email client and re-open before working in email after the conclusion of the maintenance window.
As always, for any Vistage-related technical issues, please contact Vistage IT Support at 888.261.3911, support@vistage.com, or start a chat at http://chat.vistage.com. Vistage Support hours: Monday–Friday, 6 a.m.–6 p.m PT
Posted Feb 16, 2024 - 11:36 PST
This scheduled maintenance affected: Email Services (Chair email (@vistagechair.com and @vistagechair.co.uk), Staff email (@vistage.com and @vistage.co.uk)).