IT SERVICE ADVISORY: Vistage.com, MyVistage, ChairApp and other sites affected by Hosting Provider Issue

Incident Report for Vistage

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 16:24 PDT

Investigating

IT SERVICE ADVISORY: Vistage.com, MyVistage, ChairApp affected by Hosting Provider Issue

MyVistage, ChairApp, Vistage.com, .co.uk and several other systems including our speaker scheduling system are currently unavailable due to an issue with our hosting provider. They are working to identify the cause and restore service.
Posted Aug 11, 2026 - 11:08 PDT
This incident affected: MyVistage Member and Chair portals (MyVistage Portal, Chair App, Matrix speaker scheduling system) and Vistage.com site, Vistage.co.uk site.