VISTAGE IT SERVICE ADVISORY: Business Valuation Tool (fixed) and Concur Expense Reporting Degraded - Investigating

Incident Report for Vistage

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 11:01 PST

Monitoring

The Business Valuation Tool is now available again in MyVistage, our apologies for the disruption.

Work continues on restoring the Concur connection, however Concur can still be accessed directly (please contact Support for instructions 888.261.3911 | support@vistage.com | chat.vistage.com )
Posted Jan 31, 2025 - 14:51 PST

Update

We are continuing to work with our vendors on resolving the connection issue, we hope to restore access to the Business Valuation Tool by the end of the day.

Staff, speakers or Chairs that need access to Concur today can be setup to login to Concur directly, if you have not previously had direct access please contact Support for instructions 888.261.3911 | support@vistage.com | chat.vistage.com
Posted Jan 31, 2025 - 12:25 PST

Identified

We have identified an issue with one of our vendors used for 3rd party platform connections, and as a result Concur and the Business Valuation Tool are temporarily inaccessible via MyVistage. We are working to restore these connections as soon as possible, apologies for the disruption.
Posted Jan 31, 2025 - 07:53 PST

Investigating

We are currently investigating this issue.
Posted Jan 30, 2025 - 19:26 PST
This incident affected: MyVistage Member and Chair portals (MyVistage Portal, Concur Expense Reporting).