Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 23, 2024 - 18:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 23, 2024 - 16:45 PST
Scheduled
Scheduled - IT SERVICE ADVISORY: Chairmail & Staff Email Maintenance - Friday, Feb. 23 - 6 p.m. PST start
Friday, Feb 23 - Beginning at 6 p.m. PST, Chairmail & Staff Email services will be unavailable as we perform priority maintenance. Full restoration of email services is expected by 11 p.m. Any messages received during this time will be queued and released upon completion of the maintenance.
Please ensure you close/restart Outlook before working in email after the maintenance period. For status updates on this maintenance & future maintenance events, choose subscribe to updates at http://status.vistage.com
As always, for any Vistage-related technical issues, please contact Vistage IT Support at: 888.261.3911, support@vistage.com, or start a chat at http://chat.vistage.com. Vistage Support hours: Monday–Friday, 6 a.m.–6 p.m PT
Posted Feb 23, 2024 - 12:06 PST
This scheduled maintenance affected: Email Services (Chair email (@vistagechair.com and @vistagechair.co.uk)).