IT SERVICE ADVISORY: Slow Load Times for MyVistage Top-Navigation Menu Items
Incident Report for Vistage
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 19:06 PDT
Investigating
Some pages in MyVistage are currently loading slowly or may be missing the menu options at the top of the page - we are working with our vendors to resolve this as soon as possible and will provide further updates asap, our apologies for the disruption.
Posted Oct 09, 2023 - 14:54 PDT
This incident affected: MyVistage Member and Chair portals (MyVistage Portal).