Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 01, 2023 - 19:01 PDT
Scheduled
IT SERVICE ADVISORY: Chairmail Maintenance - Tonight, Wednesday, Nov. 1, 7 - 8 p.m. PDT
This evening, beginning at 7 p.m. PDT, we will be performing Chairmail maintenance. Vistage Chairmail may be intermittently available during this time. Messages received during the maintenance period will be queued and released upon completion. Maintenance duration is expected to be one hour with full restoration of services by 8 p.m. Please close your email client and re-open before working in email after the conclusion of the maintenance window.
As always, for any Vistage-related technical issues, please contact Vistage IT Support at 888.261.3911, support@vistage.com, or start a chat at http://chat.vistage.com.
Vistage Support hours: Monday–Friday, 6 a.m.–6 p.m
Posted Nov 01, 2023 - 16:06 PDT
This scheduled maintenance affected: Email Services (Chair email (@vistagechair.com and @vistagechair.co.uk)).