Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 28, 2025 - 19:00 PST
Scheduled
IT SERVICE ADVISORY: Fri., Feb. 28, 7 - Midnight - Member Payment System & Virtual access to FIN/ACCT systems
Friday, February 28, starting at 7 p.m. PST, access to the following systems will be intermittent or unavailable as we perform system maintenance:
Member Payment System Virtual desktop access to FIN/ACCT system & custom apps
Duration of maintenance is expected to be five hours with full restoration of services by midnight.
Need assistance with a Vistage-related technical issue? Reach out to our IT Support team! 888.261.3911 | support@vistage.com | chat.vistage.com Vistage IT Support is staffed M - F, 6 a.m. - 6 p.m. PT
Posted Feb 28, 2025 - 11:05 PST
This scheduled maintenance affected: San Diego HQ Office Services (Accounting platforms) and MyVistage Member and Chair portals (Member payment system).