Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2023 - 18:00 PDT
Scheduled
IT SERVICE ADVISORY: Back-end MyVistage Maintenance – Friday, Sep. 22, 6 p.m. start
Friday, September 22, beginning at 6 p.m. PDT, Vistage IT will be performing back-end maintenance on the MyVistage site. While we don’t expect any disruption, there is a chance that areas of the site will be temporarily slow or not respond. Duration of maintenance is expected to be four hours with full restoration of service by 10 p.m.
Need assistance with a Vistage-related technical issue? Reach out to our IT Support team! 888.261.3911 | support@vistage.com | chat.vistage.com
Vistage IT Support is staffed M - F, 6 a.m. - 6 p.m., Sat - Sun, 8 a.m. - 5 p.m. PT
Posted Sep 21, 2023 - 10:12 PDT
This scheduled maintenance affected: MyVistage Member and Chair portals (MyVistage Portal).