IT SERVICE ADVISORY: Concur expense reporting link unavailable

Incident Report for Vistage

Resolved

This incident has been resolved.
Posted Jul 25, 2024 - 08:56 PDT

Identified

Following a system change by our expense reporting vendor the MyVistage link to access Concur is currently not working. US and UK staff, Chairs and speakers needing to submit or update expense reports are affected.

For immediate access to Concur our support teams are available to walk users through setting up direct Concur access (this process takes 5-10 minutes) - otherwise we expect this link to be restored in the next few days.

For assistance, please contact Vistage Support at support@vistage.com, 888.261.3911, or http://chat.vistage.com - or check back here to confirm when the link has been restored.
Posted Jul 19, 2024 - 10:30 PDT
This incident affected: MyVistage Member and Chair portals (Concur Expense Reporting).