Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2024 - 18:00 PST
Scheduled
Vistage IT Service Advisory: Friday, March 8, 6 – 11 p.m. PT - MyVistage Systems Maintenance
Friday evening, March 8, starting at 6 p.m. PT we will be performing maintenance to several back-end integration servers. While MyVistage and Chair App will be online, certain features will be temporarily unavailable:
Duration of maintenance is expected to be five hours with full restoration of services by 11 p.m.
Need assistance with a Vistage-related technical issue? Reach out to our IT Support team! 888.261.3911 | support@vistage.com | chat.vistage.com Vistage IT Support is staffed M - F, 6 a.m. - 6 p.m. PT
Posted Mar 07, 2024 - 13:03 PST
This scheduled maintenance affected: MyVistage Member and Chair portals (MyVistage Portal, Chair App, Matrix speaker scheduling system, Online Membership Application).