Chair 'Edit Meeting Notice' feature affected by latest Chrome v131 update
Incident Report for Vistage
Resolved
A fix for the Chrome issue has been released at around 930am PT Monday 11/18. If you are still experiencing issues please contact the support team at 888.261.3911 | support@vistage.com | chat.vistage.com
Posted Nov 18, 2024 - 09:31 PST
Identified
On Friday November 15th we received first reports of an issue with the Edit Group Meeting Notice feature in MyVistage, affecting Chairs using Chrome browsers that have updated to the latest v131 release (this version started rolling out to Chrome users on Thursday). On saving the meeting notice a red Failure message appears in the browser.

We are working to implement a fix for the issue as soon as possible, in the meantime Chairs needing to edit a group meeting are recommended to temporarily use Firefox, Safari or Edge browsers instead. Other vendors and web sites have also been reporting issues with this latest Chrome release, so a fix may also be released by Google.

For further assistance please reach out to our Support team at 888.261.3911 | support@vistage.com | chat.vistage.com (M - F, 6 a.m. - 6 p.m. PT)
Posted Nov 15, 2024 - 19:37 PST
This incident affected: MyVistage Member and Chair portals (MyVistage Portal).