IT SERVICE ADVISORY: ChairApp, Online Member App & PW resets not working properly

Incident Report for Vistage

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 11:21 PST

Investigating

We are investigating reports of degraded performance with ChairApp, the Online membership application and password resets.
Posted Feb 24, 2025 - 09:21 PST
This incident affected: MyVistage Member and Chair portals (Chair App, Online Membership Application).