Chair App - Chair Reports not currently displaying

Incident Report for Vistage

Resolved

This issue has been resolved as of 0915 PT, again our apologies the disruption. If you are still experiencing issues with accessing Chair Reports please contact 888.261.3911 | support@vistage.com | chat.vistage.com
Posted Feb 10, 2025 - 09:26 PST

Investigating

We are currently investigating an issue in the Chair App, Report Center feature that is preventing reports from displaying after a report link has been selected. Our apologies for the disruption.
For further support please contact 888.261.3911 | support@vistage.com | chat.vistage.com
Posted Feb 10, 2025 - 09:22 PST
This incident affected: MyVistage Member and Chair portals (Chair Report Center).