Chair Reports feature currently unavailable in Chair App

Incident Report for Vistage

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 11:13 PST

Investigating

We are currently investigating an issue that is preventing display of Chair Reports within Chair App, reports are failing to load or prompting for a login. Our apologies for the disruption, we are working to restore this feature as soon as possible.
Posted Feb 09, 2026 - 09:03 PST
This incident affected: MyVistage Member and Chair portals (Chair Report Center).