IT SERVICE ADVISORY: Network Issue Affecting Calls to Vistage IT Support

Incident Report for Vistage

Resolved

This incident has been resolved.
Posted Dec 19, 2023 - 12:21 PST

Identified

We are working on replacing failed network equipment that is preventing calls to our IT Support Teams. In the interim, the Vistage Helpdesk and Online Support teams can be reached via https://chat.vistage.com or support@vistage.com.
Posted Dec 19, 2023 - 08:50 PST
This incident affected: San Diego HQ Office Services (HQ Network).