VISTAGE IT SERVICE ADVISORY: Member payment system unable to accept payments & process payment method changes
Incident Report for Vistage
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 11:14 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2024 - 10:24 PDT
Investigating
Our member payment platform is currently unable to accept payments and changes to payment sources. Our payment portal vendor is working to resolve the issue. There is no ETA for restoration of these services at this time.
Posted Sep 13, 2024 - 10:17 PDT
This incident affected: MyVistage Member and Chair portals (Member payment system).