Minor disruption to speaker-related features in Chair App and MyVistage

Incident Report for Vistage

Resolved

Normal services restored 930am PT, again our apologies for the disruption.

As always, for any Vistage-related technical issues, please contact Vistage IT Support at 888.261.3911, support@vistage.com, or start a chat at http://chat.vistage.com. Vistage Support hours: Monday–Friday, 6 a.m.–6 p.m. (PT)
Posted Sep 12, 2026 - 11:43 PDT

Identified

During maintenance on Friday evening a service failed that supports some speaker-related features in MyVistage and ChairApp, we are working to restore these features as soon as possible, our apologies for the disruption.
Posted Sep 11, 2026 - 23:15 PDT
This incident affected: MyVistage Member and Chair portals (MyVistage Portal, Chair App, Speaker Directory, Meeting Notices).